Need to manually connect to WiFi every time?

Discussion in 'Spark Discussions' started by allakazam, Feb 19, 2018.

  1. allakazam

    allakazam New Member

    Joined:
    Jan 28, 2018
    Messages:
    3
    Likes Received:
    2
    Hi all,

    I’m a Mavic flyer who recently bought a Spark + Remote. I was setting it up yesterday (went through the frustrations of QR scanning not working) and I linked the RC to the Spark. I have an iPhone X. With my Mavic, whenever I power it on with the Mavic remote, my phone registers and recognizes it via the DJI Go4 App. Is this because of Ocusync? I know the Spark is strictly a WiFi aircraft, but it’s a serious pain in the *** because whenever I boot up the bird + RC, I need to manually join the RC WiFi network every single time. I have that WiFi network set to auto join on my phone, but it’s just an additional step. I kind of want to emulate my Mavic experience (turn on the Mavic, turn on the RC, open the DJI app and fly) rather than what I’ve had to do so far (turn on the drone, turn on the RC, open up my iPhone settings and join the RC WiFi network, open up DJI Go and then fly). I know this is bickering for just an extra step, but I’m wondering if there is a work around or whether I’ll have to always manually join the RCs WiFi network every time. Thanks in advance.

    Allakazam
     
  2. allakazam

    allakazam New Member

    Joined:
    Jan 28, 2018
    Messages:
    3
    Likes Received:
    2
    I’m an idiot, I figured it out. When I have the OTG cable plugged in to the remote, it will auto connect. Without the OTG cable, I need to manually connect to the RCs wifi network.
     
  3. NyJosh

    NyJosh Well-Known Member

    Joined:
    Jan 23, 2018
    Messages:
    64
    Likes Received:
    30
    Glad you sorted it out. For me, I reverse the steps a bit. I always turn on my remote first, then Spark, then launch the app. I want to say my iPhone X joins automatically, but I think the RC takes a little bit to start broadcasting the SSID and allow connections. Try turning on the remote while not connected to other WiFi sources and give it a couple minutes to see if it joins automatically.